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Travail Pratique 1

Le but de ce travail est d’initier l’étudiant à l’utilisation d’un logiciel de
création 3D. Ce travail, sous forme de tutorial, montrera quelques-unes des
méthodes de modélisation et de rendu d’images de synthèse.

Au final, l’étudiant devra modéliser et illuminer une scène comprenant
un bonhomme de neige :

1 Installation de Blender

Pour installer Blender, rendez-vous sur la page : http://www.blender.
org et cliquez sur Blender 2.56 Beta. Blender peut être installé sur Linux,
Mac ou Windows, prenez soin de télécharger la bonne version.
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Nous utiliserons une configuration spécifique de Blender dans ce tp. Pour
ce faire, démarrez Blender et allez au menu File → User Preferences.

– Onglet Input : Cochez la case Emulate 3 Button Mouse.
– Onglet System : Cochez la case VBOs.

2 Modélisation

2.1 Modélisation du sol

1. Sélectionnez le cube avec le bouton droit de la souris.

2. Supprimez-le de la scène en utilisant la touche x et confirmez l’action.

3. Pour ajouter un plan à la scène, utilisez le menu Add → Mesh → Plane

(le raccourci clavier est Shift-a).

4. Nous voulons maintenant agrandir le plan pour qu’il puisse contenir
la scène. Pour ce faire, nous allons utiliser une des trois opérations de
base : le scaling (les autres étant la translation et la rotation). Remar-
quez les trois axes x, y et z de l’objet, pour agrandir l’objet, nous
allons utiliser l’action de scaling deux fois : une fois en x et l’autre en
y.

Pour agrandir en x, appuyez sur la touche s (active le mode scaling)
suivi de x (vérouillez le scaling sur l’axe des x) et agrandir d’environ 10
unités (le nombre d’unités et la direction du scaling sont affichés en bas
à gauche de la fenêtre d’édition). Pour confirmer, appuyez sur le bouton
gauche de la souris (le bouton droit permet d’annuler l’action).

Faites maintenant un scaling selon l’axe des y de 8 unités (touche s

suivi de y). Vous devriez obtenir un plan similaire à la figure 1.

2.2 Modélisation du tronc

Comme tout bon logiciel graphique, Blender possède un système de couches
(layers) permettant d’isoler l’édition d’objets. Déplacez un objet vers une
autre couche permet aussi d’améliorer les performances de l’éditeur 3D étant
donné que le nombre d’objets affichés à l’écran est réduit.
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Figure 1 – Sol après scaling

Figure 2 – Système de couches

Blender possède 20 couches pouvant être accedées à partir des boutons
au bas de la fenêtre d’édition (voyez la figure 2).

1. Déplacez-vous vers une autre couche.

2. Ajouter une UV Sphere à la scène (menu Add → Mesh → UV Sphere).
Remarquez les options apparaissant en bas à gauche de la fenêtre. Elles
permettent de complexifier ou de simplifier le maillage ajouté, pour
notre cas, nous garderons les paramètres par défaut.

3. Vous pouvez scaler l’objet en z pour lui donner une forme un peu
applatie.

4. Dans cette étape, nous allons dupliquer la sphère et la déplacer au
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dessus de la sphère actuelle. Pour obtenir plus de précision lors des
déplacements il peut être utile d’utiliser la vue en mode orthographique
plutôt que perspective. Pour changer de mode projection perspective

→ projection orthographique, appuyez sur la touche 5 du clavier
numérique (généralement le 5 de la partie droite du clavier).

Pour vous aider lors du déplacement de la sphère, il peut être utile de
se placer en vue de côté en utilisant la touche 1 du clavier numérique,
les touches 7 et 3 vous permettent de changer la vue vers l’axe des z et
x respectivement.

Pour dupliquer la sphère, sélectionez-la avec le bouton droit de la souris
et appuyez sur Shift-D (ou menu Object → Duplicate). Vous serez
automatiquement placés en mode translation, vérouillez l’axe des z en
appuyant sur la touche z et déplacez la sphère en bougeant la souris
sur le dessus de la sphère originale. Confirmez la position finale avec le
bouton gauche de la souris (comme à l’habitude le bouton droit annule
l’action).

5. Vous pouvez réduire la taille de la seconde sphère en utilisant la fonction
de scaling vue précédemment. Utilisez le scaling sans spécifier d’axes
permet d’obtenir une transformation uniforme dans toutes les axes,
c’est ce que l’on souhaite dans ce cas ci.

6. Il est possible qu’après l’opération de scaling, la seconde sphère ne
soit plus au bon endroit. Pour la déplacer, il suffit de la sélectionner et
d’appuyer sur g (pour grab) pour enclencher la translation. Tout comme
l’opération de scaling, les axes peuvent être verrouillés en appuyant sur
x, y ou z.

7. Ajoutez la tête du bonhomme en ajoutant une UV sphere à la scene.
Déplacez et scalez l’objet convenablement (référez-vous à la figure 3)

2.3 Ajout des détails au corps et à la tête

2.3.1 Ajout des boutons

1. Ajoutez une UV sphere à la scène et déplacez/redimensionnez-la sur le
corps du bonhomme.

2. Ajoutez-en deux autres en dupliquant le bouton (menu Object →
Duplicate) pour obtenir un résultat similaire à la figure 4.
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Figure 3 – Tronc et tête

2.3.2 Ajout de la bouche et des yeux

Répétez les étapes de la section précédente pour ajouter une bouche et
des yeux au personnage (voir la figure 5).

2.3.3 Ajout du nez

Pour modéliser le nez, nous allons nous servir d’une nouvelle primitive :
le cône.

1. Ajoutez un Cône à la scène (menu Add → Cone.

2. Déplacez/Redimensionnez pour qu’il soit à l’échelle par rapport à la
tête du personnage.

3. Le cône ajouté n’aura probablement pas la bonne orientation, nous
allons utiliser l’opération de rotation pour y remédier. Appuyez sur r

pour enclencher la rotation, tout comme la translation et le scaling il
est possible de verrouiller la rotation sur un axe en appuyant sur x, y

ou z. Dans notre cas, la rotation se fait par rapport à l’axe des x.

4. Déplacez le nez au besoin pour obtenir un résultat semblable à la figure
6.
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Figure 4 – Boutons

Figure 5 – Bouche et yeux
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Figure 6 – Bouche et yeux

5. La forme du personnage étant maintenant complétée, déplacez-la vers
la couche contenant le sol en utilisant la touche a pour tout sélectionner
et la touche m pour déplacer les objets vers la première couche.

6. Déplacez au besoin le personnage avec l’opération de translation (touche
g) pour qu’il soit sur le sol plutôt que dans le sol (voir figure 6).

2.4 Modélisation des bras

Pour obtenir un objet d’apparence plus complexe, il est souvent utile de
pouvoir éditer la géométrie des objets que nous ajoutons à la scène, c’est ce
que nous allons faire pour la modélisation des bras.

1. Déplacez-vous vers une couche vide et ajoutez une cylindre à la scène.

2. Faites une rotation de 90 degrés selon l’axe des y. Vous pouvez spécifier
l’angle de rotation direction en entrant 90 lorsque vous êtes en mode ro-
tation. Par exemple, appuyez sur r suivi de y vérouille la rotation selon
l’axe des y, tapez 90 pour effectuer la rotation de 90 degrés exactement.
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Figure 7 – Cylindre du bras

3. Redimensionnez le cylindre selon le plan yz en appuyant sur s suivi
de Shift-x (l’axe perpendiculaire au plan de scaling) pour obtenir un
cylindre ayant une forme similaire à la figure 7.

4. Sélectionnez le cylindre en cliquant avec le bouton droit de la souris sur
celui-ci et appuyez sur la touche Tab pour passer en mode édition. Re-
marquez qu’il est maintenant possible de voir la composition géométrique
de l’objet.

5. Appuyez sur Ctrl-Tab et sélectionnez Edge, ceci permet l’édition d’arêtes.

6. Appuyez sur la touche a pour désélectionner l’ensemble des arêtes.

7. Nous allons maintenant ajouter de la géométrie à l’objet en utilisant
la technique de loop cut. Appuyez sur Ctrl-r pour activer le loop cut,
votre fenêtre d’édition devrait ressembler à celle de la figure 8.

8. Avec la molette de votre souris, ajoutez 10 anneaux supplémentaires à
l’objet.

9. Nous allons maintenant pouvoir éditer les anneaux pour donneer la
forme souhaitée à l’objet. Sélectionnez tout d’abord le mode propor-
tional editing (l’anneau bleu de la figure 9) permettant d’étendre
l’édition de la géométrie au voisinage de la sélection. Assurez-vous aussi

8



Figure 8 – Loop-cut sur un cylindre

Figure 9 – Option d’édition

que la sélection des surfaces cachées soit permise en désactivant le bou-
ton limit selection to visible (voir le carré à gauche de la figure 9).

10. Passez en projection orthographique (avec le bouton 5 du clavier numérique)
et en vue du plan xz (bouton 1 du clavier numérique).

11. Assurez-vous tout d’abord que rien n’est sélectionner (avec la touche
a). Sélectionnez par la suite un des anneaux à l’aide de la sélection par
boite (touche b) comme à la figure 10.

12. À l’aide des opérations de translation/rotation/redimensionnement ap-
prises précédemment, changez la forme de l’objet pour obtenir une
forme similaire avec à la figure 11. Notez que vous pouvez changer le
voisinage affecté par le mode proportional editing en ajustant le cer-

9



Figure 10 – Résultat de la sélection par boite

cle blanc apparaissant à l’écran avec la molette de la souris lorsqu’une
opération de translation/rotation/redimensionnement est activée.

13. Une fois que vous êtes satisfait de la forme du bras du personnage,
revenez au mode objet en appuyant sur Tab et déplacez le bras vers la
couche principale.

14. Déplacez/Redimensionnez le bras pour qu’il soit à un endroit conven-
able sur votre personnage.

15. Dupliquez le bras avec la touche Shift-D et placez-le de l’autre côté
du personnage (vous devriez lui appliquer une rotation de 180 degrés
par rapport à l’axe des z). Votre scène devrait maintenant ressembler
à la figure 12.

2.5 Modélisation du chapeau

1. Déplacez-vous vers une couche vide et a ajoutez une cylindre à la scène.

2. Passez en mode édition et ajoutez 8 loop-cut horizontal (Ctrl-r) comme
sur la figure 13.
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Figure 11 – Forme final du bras

Figure 12 – Personnage avec bras
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Figure 13 – Chapeau avec 8 loop-cuts

3. Désactivez le mode proportional editing et assurez-vous que la sélection
des surfaces cachées soit permise.

4. Placez la vue selon l’axe des y (touche 1 sur le clavier numérique) et
assurez-vous d’être en vue projection orthogonale.

5. Choisissez le mode de sélection Edge (touche Ctrl-Tab) et à l’aide
de la sélection par bôıte (touche b), sélectionnez l’anneau inférieur du
cylindre comme à la figure 14.

6. Nous allons maintenant utiliser l’opération d’extrusion pour créer le
rebord du chapeau. L’extrusion permet de créer de la géométrie addi-
tionnelle en dupliquant la sélection selon le mode d’édition (sommet,
arrête ou face) en direction de la normale au sommet.

Pour créer le rebord du chapeau, nous allons combiner extrusion et
redimensionnement. Appuyez tout d’abord sur la touche e pour ex-
truder la sélection. Vous remarquez que vous pouvez déplacer la nou-
velle géométrie dans la direction de la normale. Étant donné que le
rebord est perpendiculaire à la normale, nous allons combiner l’extru-
sion à un redimensionnement en xy. Donc appuyez sur la touche s pour
suivi de Shift-z pour verrouiller selon le plan xy et ajustez la taille
du rebord à votre goût (voir figure 15).

7. De la même manière que vous créé le bras du personnage, vous pouvez
modifier la forme du chapeau en déformant les anneaux ajoutés lors de
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Figure 14 – Sélection de l’anneau du bas

Figure 15 – Création du rebord

13



Figure 16 – Forme du chapeau

l’opération de loop-cut pour donner un résultat similaire à la figure 16.

8. Déplacer le chapeau vers la couche principale et modifier sa position et
sa taille pour le placer sur la tête du personnage.

2.6 Modélisation du lampadaire

Ajouter un cylindre et un cône à la scène pour modéliser le lampadaire
(référez-vous à la figure 17).

3 Matériaux

Avant d’ajouter les lumières à la scène, nous devons spécifier les propriétés
des matériaux qui dicteront comment ceux-ci interagiront avec la lumière.
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Figure 17 – Modélisation du lampadaire

3.1 Roche

1. Sélectionnez une sphère composant le sourire de votre personnage avec
le bouton droit de la souris

2. Le panneau de droite de Blender permet d’éditer les propriétés de la
scène et de ses objets. Sélectionnez l’onglet Material (voir la figure 18).

3. Appuyez sur New pour créer un nouveau matériel. Nommez le mat roche.

4. Cliquez sur Diffuse et donnez-lui une couleur appropriée. Ajustez l’in-
tensité de la composante diffuse à environ 0.8 et l’intensité spéculaire à
0.01. Choisissez le modèle de CookTorr pour la composante spéculaire
en ajustant le Hardness à 10.

5. Assignez le nouveau matériel aux roches de votre personnage (la bouche
et les boutons).

3.2 Matériel oeil, nez et chapeau

Créez un matériel différent pour représenter les yeux, le nez et le chapeau
du personnage à l’aide des composantes diffuse et spéculaire des matériaux.
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Figure 18 – Option Material
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3.3 Matériel bois

1. Sélectionnez un bras du personnage et créez un nouveau matériel et
nommez-le mat bois.

2. Donnez lui une couleur diffuse brune et placez l’intensité spéculaire à
0.

3. Nous allons maintenant ajouter une texture bump map au matériel qui
modifiera les normales géométriques lors de l’étape d’illumination pour
donner l’illusion d’une géométrie plus complexe.

Déplacez-vous vers l’onglet Texture et créez une nouvelle texture nommée
tex bois (voir figure 19).

4. Choisissez le type Wood.

5. Dans la sélection influence, décochez Color et cochez plutôt l’option
Normal.

6. La texture Wood est une texture dite procédurale (vs. une texture image
comme les formats bitmaps, jpg, png, etc.) permettant d’être configurée
à partir de paramètres (voir figure 20). Utilisez Band Noise pour la
texture.

7. Assignez le matériau à l’autre bras et au lampadaire.

3.4 Matériel lampe

1. Sélectionnez le cône représentant la lampe et créez un nouveau matériel
nommé mat lampe.

2. Laissez la couleur blanche pour les composantes diffuse et spéculaire.

3. Cochez l’option Mirror et ajustez les paramètres tel que montré sur
la figure 21. Ceci permettra le reflection des objets de la scène sur la
lampe pour simuler un matériau métalique.

3.5 Matériel neige

Pour simuler l’apparence de la neige nous allons combiner les méthodes
utilisées pour les matériaux précédents soit la réflection miroir et le bump

mapping.
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Figure 19 – Option Texture
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Figure 20 – Option Wood

Figure 21 – Option Mirror
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Figure 22 – Option Mirror pour la neige

1. Ajoutez un nouveau matériau à l’objet sol et nommez-le mat sol.

2. Gardez la couleur blanche pour la composante diffuse et spéculaire et
ajustez l’intensité spéculaire à 0.5 avec un Hardness de 50.

3. Ajustez l’option Mirror à partir de la figure 22.

4. Nous allons maintenant ajouter une texture pour le bump mapping de
la même manière que pour le matériau de bois. Plutôt que d’utiliser
la texture Wood prenez le type Stucci et gardez les paramètres par
défaut. N’oubliez pas de décocher Color et de cochez Normal dans la
section Influence.

5. Assignez le matériel de neige au personnage.

4 Lumières

Dans cette section nous allons ajouter l’éclairage de la scène. Vérifiez tout
d’abord qu’aucune lumière n’est présente dans la scène (vérifiez en particulier
pour la lumière Lamp faisant partie de la scène par défaut).
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Figure 23 – Orientation de la lumière de type Spot

4.1 Lumière de type Spot

1. Ajoutez une lumière de type Spot à la scène : Add → Lamp → Spot.

2. Déplacez la lumière à l’intérieur du cône représentant la lampe à l’aide
de l’opération de translation (bouton g).

3. Orientez la lumière pour qu’elle pointe sur le personnage à l’aide de
l’opération de rotation (bouton r). La figure 23 montre l’orientation de
la lumière.

4. À partir du panneau de droite, allez aux propriétés de la lumière (voir
figure 24).

5. Changez la couleur de la lumière à votre goût et assurez-vous que les
options Specular et Diffuse soient cochées.

6. La section Shadow permet de configurer l’algorithme qui sera utilisé
pour générer l’ombrage de la lumière. Assurez-vous que l’option sélectionné
soit Buffer Shadow et que le buffer type soit à Classic-Halfway.

7. La section Spot Shape permet de changer la forme de la lumière. Assurez-
vous que la lumière couvre entièrement votre personnage en modifiant
l’attribut size. Vous pouvez cochez l’option Show Cone pour visualiser
la forme de la lumière.
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Figure 24 – Propriétés de la lumière de type Spot
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8. Placez l’option Blend à 0.5 pour avoir un dégradé aux abords de la
lumière et cochez l’option Halo avec une intensité d’environ 0.03 pour
simuler l’interaction de la lumière avec son milieu.

4.2 Lumière de type Hemi

Nous allons ajouter une lumière de type hémisphérique pour simuler la
réflection de la lumière sur la neige. Ce type de lumière ne génère pas d’om-
brage.

1. Ajoutez une lumière de type Hemi à la scène : Add → Lamp → Hemi.

2. Effectuez une rotation de 180 degrés de la lumière pour qu’elle puisse
pointer vers le ciel de la scène.

3. Changez la couleur de la lumière vers un gris foncé (environ R = 0.2
G = 0.2 B = 0.2).

4. Changez l’énergie de cette lumière à environ 0.5.

4.3 Lumière d’environement

1. L’effet de l’environment sur les objets de la scène est configurée à partir
du panneau World (voir figure 25).

2. Cochez l’option Environment Lighting et utilisez les paramètres de
la figure 25. L’option Gather devrait être aussi placée à Approximate

avec les paramètres de la figure 25.

3. Cochez l’option Stars et changez ses paramètres à votre goût pour
donner un ciel étoilé. Ajustez l’horizon color en conséquence et cochez
l’option real sky.

5 Rendu de la scène

Pour faire le rendu de la scène, utilisez le menu Render → Render Image

ou la touche F12. Assurez-vous que tous vos objets sont rendus en mode

23



Figure 25 – Propriétés des effets d’environement
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Smooth. Pour ce faire appuyez sur a pour sélectionnner tout les objets de
la scène et appuyez sur le bouton Smooth sur le panneau de gauche. Vous
pouvez interrompre le rendu à tout moment avec la touche Esc. Si vous êtes
satisfait du résultat, le menu Image → Save As vous permet de sauver le
résultat. Pour revenir à la fenêtre d’édition 3D, appuyez sur Shift-F5.
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